Forums - C# Corner

Forum guidelines

How to use SAPI4

Oct 23 2008 6:07 AM
Hello,
I have a text-to-speech application and I want to be able to support SAPI version 4 as well as SAPI5.
There are at least two methods I know of to use SAPI5:
  1. Use the new System.Speech namespace, or
  2. To be .NET 2.0 compatible, use COM interop (via the auto-generated SpeechLib.dll).
I am using the second method, and I can only access SAPI5 speech synthesizers it seems.
What would I need to use/do to make use of SAPI4 as well?

Thanks in advance for any help!

Daniel

Download Free eBooks

SPONSORED BY

File APIs for .NET
Aspose are the market leader of .NET APIs for file business formats – natively work with DOCX, XLSX, PPT, PDF, MSG, MPP, images formats and many more!