AWS SDK For Python And CLI v1 Deprecates Python 3.4 And 3.5

This deprecation will not affect users using Python 2.7

Recently, Amazon announced that starting February 1, 2021, the AWS SDK for Python (Boto3 and Botocore) and the AWS Command Line Interface (AWS CLI) v1 will no longer support Python 3.4 and Python 3.5.

The company encouraged developers to upgrade to Python 3.6 or later. This deprecation will not affect users using Python 2.7

Amazon said that for services hosted on Amazon Elastic Compute Cloud, most AWS Quick Start AMIs now provide Python 3.6+ out of the box.

 

Source: AWS

The company strongly encouraged AWS CLI users to migrate to AWS CLI v2. AWS CLI v2 doesn’t have a dependency on a local Python runtime, which allows users to avoid these deprecations in the future. 

You can visit 'Installing, Updating, and Uninstalling the AWS CLI Version 2' for installation instructions.