Issue

The SharePoint 2010 Administration Service does not start in one or any of the Servers. Additionally, the following errors are logged in Event Viewer on the SharePoint server when trying to start the SharePoint 2010 Administration Service.

Error: 1053: The service did not respond to the start or control request in a timely fashion.

Impact

No administration tasks can be run, like Deployment and Retraction of solution WSP packages etc.

Resolution

Manually start the administration job by executing the following PowerShell command after scheduling any administration job.

For load balanced (multi WFE) environments, the Start-SPAdminJob command needs to be run on every server after scheduling each admin job.

Problem Scenario

Deploying a WSP file with SharePoint 2010 Administration service stopped.

Reference Links: