How to Work With EIGRP Protocol

In this article I am going to explain the EIGRP protocol in networking.

Introduction

In this article I am going to explain the EIGRP protocol in networking. EIGRP is defined as Enhanced Interior Gateway Routing Protocol. EIGRP is a routing protocol that specifies how routers communicate with each other.

A routing protocol is used for communication among two or more routers. There are two type of routing used to create a network; they are:

  • Static routing
  • Dynamic routing 

Static Routing

Implementation of static routing is hard and complicated. In this type of routing we set all routes manually and it is suitable for a small network.

Dynamic Routing

In a dynamic routing protocol we use some routing protocol to set the route. There are two types of routing protocols; they are:

  • Interior gateway routing
  • Exterior gateway routing

Interior gateway routing

Interior gateway routing has two types of protocols; distance vector routing protocol and link state routing protocol.

(Enhanced Interior Gateway Routing Protocol (EIGRP)

Enhanced Interior Gateway Routing Protocol (EIGRP) is a Cisco proprietary routing protocol. EIGRP is known as a hybrid protocol because it has the mix of features of distance vector routing protocol and link state routing protocol.  We can say that EIGRP is an updated version of IGRP.  

EIGRP works on the diffusing update algorithm (DUAL).  It allows a maximum number of hops of 255. By default it  allows 100 hops. Path selection is based on the metric value of the route. In EIGRP the metric is computed based on the bandwidth of the route, not the number of hops like RIP. 

When we are configuring eigrp we need to provide an Autonomous System (AS) value.

EIGRP maintains three types of tables, they are:

  • Neighbor table
  • Topology table
  • Routing table

Neighbor Table

A Neighbor table contains information about a neighbor router. It is a directly-connected EIGRP enabled router. Neighbors are simply discovered by a simple hello packet.

Topology Table

A Topology table contains a list of destination networks in the EIGRP-routed network together with their respective metrics.

Routing Table

A Routing table contains the routes to all destinations. A Routing table is created from a topology table. It has a successor and a feasible successor.

Example

Here we are creating a network using the RIP protocol. In this network we have three routers, three switches and six PCs.

eigrp routing.jpg

Configuration of Router 2

Router>enable
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#host
Router(config)#hostname A
A(config)#interface fastEthernet 0/0
A(config-if)#ip address 192.168.1.1 255.255.255.0
A(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

A(config-if)#exit
A(config)#interface fastEthernet 0/1
A(config-if)#ip address 192.168.2.1 255.255.255.0
A(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

A(config-if)#exit
A(config)#router eigrp 10
A(config-router)#network 192.168.1.0
A(config-router)#network 192.168.2.0

Configuration of Router 3

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up    
   
Router(config-if)#do ping 192.168.2.1
Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 3/4/7 ms
Router(config-if)#exit

Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
outer(config)#interface ethernet 1/0
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Ethernet1/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet1/0, changed state to up

Router(config-if)#exit
Router(config)#router eigrp 10
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.4.0

Configuration of Router 4

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.4.2 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Router(config-if)#exit

Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.5.1 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit

Router(config)#router eigrp 10
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.5.0

 

PC 1 communicated with PC 4

EigrpRouting.jpg

PC 3 communicated with PC 0

DynamicRouting.jpg

It show route of Router 2

show ip route.jpg

It show route of Router 3

ip route.jpg

It show route of Router 4

show route.jpg