Sync Button Missing In SharePoint Online Doc Library - Project Site Template

This article is going to be a simple one. I’ll be sharing my recent experience with SharePoint Online when the ‘’Sync Button“ which you see on the document library went missing all of a sudden. If you’re not sure about what I’m talking about, this image below should help you understand.


So a  couple of days back , a user who is always known for finding bugs in SharePoint called me and said, ‘”Hey the Sync button is missing in SharePoint Online doc library. ”  I felt that couldn't be possible and I wanted to double check that. So, I went ahead and took a look at the document library on a SharePoint Online team site only to find that nothing was wrong with the “Sync button” and it was showing up perfectly fine.

So, I took a look at the URL which it was referring to and found that it was missing. Now, things were really bizarre to me. Upon digging further, I found that the site it was referring to was a “Project Site" and the one which I tried first was a “Team site.” Now, things got really interesting and I did some testing to isolate this issue.

I tried reproducing this issue in different site templates and found that this was something specific to “Project site" (top level sites as well as subsites that make use of Project site template) alone. As this is on SharePoint Online, I raised a premier support case to know what Microsoft had to say about this. The support engineer checked with the product group team and informed me that this is a bug which was caused post the “New Experience” rollout which was released by MS a few months back, and it seemed that many customers have already reported this issue to them.

If you’re hearing this for the first time, please take a look at this link below to understand this feature named “New Experience”.

Finally, based on my testing, what I identified is listed below.

  1. On SharePoint Online Team sites, I don’t see this issue. Please check the image below.


  2. On SharePoint Online Project sites, I can see this issue .Please check the image below (the sync button is missing)….


Note

MS has checked and confirmed that this issue is a known bug and will take atleast 3 to 6 months to get this fixed. Also, as per MS, it seems that this issue persists on other site templates also apart from “Project sites “. However, I didn’t get a chance to try them yet. So just in case you get a call or may be an email from users about this issue, please be informed that this is a known bug at the moment and will be fixed in 3 to 6 months’ time.

Workaround

The workaround for this is to -- Go to the library settings >> Go to advanced settings>> Change the option in the list experience from New to Classic experience, as shown in the image below. By doing so, you’re switching back to the previous document library experience.


Once you do that, you will notice the “Sync button” on a SharePoint Online Project site document library, as shown in the image below.


Thanks for reading this post…. I hope this will save you time in troubleshooting this issue. Happy SharePointing!!!

X

Build smarter apps with Machine Learning, Bots, Cognitive Services - Start free.

Start Learning Now