Niyazi Toros

Niyazi Toros

  • 2.1k
  • 41
  • 5.6k

I cannot get rows from reader = cmd.ExecuteReader() using SP

Jun 15 2016 5:18 AM
Hi,
 
I have an SP like this;
  1. /*Parameters*/   
  2. ALTER Procedure [dbo].[VerificationControl](   
  3.     @Value1 nvarchar(16),   
  4.     @Value2 nvarchar(4),   
  5.     @Value3 nvarchar(6),  
  6.     @Value4 nvarchar(10),  
  7.     @Value5  nvarchar(20),  
  8.     @Value6 nvarchar(20) output,  
  9.     @Value7 nvarchar(20) output,  
  10.     @Value8 nvarchar(50) output  
  11. )  
  12. AS   
  13. BEGIN  
  14. ....  
  15. .... 
 
 
I am using reader = cmd.ExecuteReader();
But I cannot get any data from while (reader.Read()).
 
When I debug I cannot enter while (reader.Read())  loop.
  1. // SET THE CONNECTIN VARIABLES  
  2. SqlConnection cnn;  
  3. cnn = new SqlConnection(connetionString);  
  4.   
  5. // SET CONNECTION AND OPEN  
  6.   
  7. SqlCommand cmd = new SqlCommand();  
  8. SqlDataReader reader;  
  9. DataTable dt = new DataTable();  
  10.   
  11. cmd.CommandText = "VerificationControl";  
  12. cmd.CommandType = CommandType.StoredProcedure;  
  13. cmd.Parameters.AddWithValue("@Value1""AAA"  
  14. cmd.Parameters.AddWithValue("@Value2""BBB"  
  15. cmd.Parameters.AddWithValue("@Value3""CCC"  
  16. cmd.Parameters.AddWithValue("@Value4""DDD"  
  17. cmd.Parameters.AddWithValue("@Value5""EEE"  
  18. cmd.Parameters.AddWithValue("@Value6""");  
  19. cmd.Parameters.AddWithValue("@Value7""");  
  20. cmd.Parameters.AddWithValue("@Value8""");  
  21. cmd.Connection = cnn;  
  22.   
  23. cnn.Open();  
  24. reader = cmd.ExecuteReader();  
  25.   
  26. while (reader.Read())  
  27. {  
  28.     string mCusName = "";  
  29.     mCusName = reader[0].ToString();  
  30.   
  31.     string mSurName = "";  
  32.     mSurName = reader[1].ToString();  
  33.   
  34.     string mStatusCode = "";  
  35.     mStatusCode = reader[2].ToString();  
  36. }  
  37.   
  38. reader.Close();  
  39. cnn.Close(); 
 
 When I look at the my SQL table that my SP works perfectly.
 
Any help plase?
 
Kind Regards

Answers (2)